Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Portal components
Christina

Will someone PLEASE help me!

 I got the current time thing up but it streches all the way across the screen. How do I make it small like the one here? www.hickorymoms.myfreeforum.org

I am also getting fed up with trying to figure out the random image thing. I have read and read and tried and tried and  tried some more on getting it up and no luck. What am I doing wrong? How come no one will help me? the above site has one but I can't figure it out. I asked them as I am on that forum but they can't remember what they did. In fact she has tried to help me but with no luck as well.  PLEASE help me get this box up. I have pictures in the gallery if you click gallery on the very bottom of the page but I want them in a box like them.  the other forum I am trying to get up and running is www.bedfordmoms.myfreeforum.org


Thank you so much for any help!
myff admin

A forum is about members and posts, all the extras may be nice but are not needed and do require you to know html coding, we can help with this but we cannot do it for you.

it is all about learning curves, if what you are trying to to is way beyond you a the moment, then pause and learn slowly.
Christina

I do want to learn and that is why I came here. I new I may be able to get  help. But I have tried everything. what I am doing is going to the edit temp and then going to the bottom box and clicking on the randomimage.tpl thing and hit submit to get a code. I then go and put it in the overall header and hit submit but it eitehr makes my page white or it shows text instead of a box for my pictures. am  i doing it wrong? I honestly learn better with help. I only get frustrated trying to figure it out on my own. bI know it is only an extra but I am trying to get my forum like the other because we are all part of t he same type of "branch".
symon

Current time seems to be fixed , as its a normal size portal..

As for random image it is as easy as adding adding

Code:
{MYFF.RANDOMIMAGE}


Alongside your other portals ?

so go to overall header find your portal codes that may look like this

Code:
<table width="100%" border="0" cellspacing="0" cellpadding="2">
  <tr>
    <td width="125" align="left" valign="top">
<!-- BEGIN switch_forum_view -->
<table><tr>
<td valign="top">
{MYFF.ANNOUNCE show_results="topics" link="FORUM"}{MYFF.STICKY show_results="topics" link="FORUM"}{MYFF.TOPPOSTERS}
</td></table>
<!-- END switch_forum_view -->
</td>
    <td valign="top" align="center">


And just add


Code:
{MYFF.RANDOMIMAGE}
symon

Ok just looked again and your not using portals, so just add

Code:
{MYFF.RANDOMIMAGE}


to your overall header , where you wish it to show.
Christina

I did that and it comes up like this on my forum

$myffcms_options["RANDOM IMAGE"]->name="RANDOM IMAGE"; $myffcms_options["RANDOM IMAGE"]->component="RANDOMIMAGE"; $myffcms_options["RANDOM IMAGE"]->title="members photos"; $myffcms_options["RANDOM IMAGE"]->show_title="1"; $myffcms_options["RANDOM IMAGE"]->guest="1"; $myffcms_options["RANDOM IMAGE"]->link="http://bedfordmoms.myfreeforum.org/viewportal.php?component=gallery"; $myffcms_options["RANDOM IMAGE"]->postable="1";
Christina

Okay so I tried it the way you said and nothing happens. It makes my frum look white with no type of design. well okay it isn't blue anymore and has no "box" look to it.

would you be willing to sing in as me and look to see if anything is screwed up or not done right? I would be more th an willing for someone to look around for me and see what might be going on. The girl who did the one on Hickory Moms says she can't figure out what happened either. she has tried to add it to mine as well and doesn't know what happened.

Thank you so much for your patience and your help.
myff admin

You need to give a link where we can actually see the problem.

We do not as a rule sign in to forums.
Christina

www.bedfordmoms.myfreeforum.org
myff admin

I see  the forum portal there, what am I meant to be looking at? wha tis currently the problem?
Christina

right now I put in the code that looks like this:


<!--BEGIN switch_random image_title -->  

       
 
<!--END switch_random image_title -->  
<!-- BEGIN random image -->
 


 
   
<!-- END random image -->
{RANDOM IMAGE_TITLE}




Well that madae my forum look white.

And if I put in this code:

$myffcms_options["RANDOM IMAGE"]->name="RANDOM IMAGE";
$myffcms_options["RANDOM IMAGE"]->component="RANDOMIMAGE";
$myffcms_options["RANDOM IMAGE"]->title="members photos";
$myffcms_options["RANDOM IMAGE"]->show_title="1";
$myffcms_options["RANDOM IMAGE"]->guest="1";
$myffcms_options["RANDOM IMAGE"]->link="http://bedfordmoms.myfreeforum.org/viewportal.php?component=gallery";
$myffcms_options["RANDOM IMAGE"]->postable="1";

It shows this on the screen. I tried putting in what you said, The {MYFF.RANDOMIMAGE} and it shows that as well.  But those are the things I have tried so far.
Christina

okay I am taking the first code off as it takes my logo away and makes it the forum white with no type of a template.
myff admin

I am totally confused. Where are you told to enter:

Code:

$myffcms_options["RANDOM IMAGE"]->name="RANDOM IMAGE";
$myffcms_options["RANDOM IMAGE"]->component="RANDOMIMAGE";
$myffcms_options["RANDOM IMAGE"]->title="members photos";
$myffcms_options["RANDOM IMAGE"]->show_title="1";
$myffcms_options["RANDOM IMAGE"]->guest="1";
$myffcms_options["RANDOM IMAGE"]->link="http://bedfordmoms.myfreeforum.org/viewportal.php?component=gallery";
$myffcms_options["RANDOM IMAGE"]->postable="1";


as far as I am aware that is taken from the export option in the portals, it is not for entering anywhere  

All you should need is to put {MYFF.RANDOMIMAGE} in overall_header.tpl and then edit cms_randomimage.tpl to your liking.
Christina

okay, I am going to try this again. should I do the {MYFF.RANDOMIMAGE} first and then go back and edit the randomimage portal?
Christina

I just noticed I have two randomimage.tpl's. One looks like this when you click submit:

Code:

<table width="100%" cellpadding="0" cellspacing="0" border="0" class="forumline" align="center">
<!--BEGIN switch_random image_title -->     
   <tr>
        <th  colspan="1" class="thTop" nowrap="nowrap">{RANDOM IMAGE_TITLE}</th>
     </tr>
<!--END switch_random image_title -->  
<!-- BEGIN random image -->
     <tr>
   <td><a href="{random image.THUMBNAIL_URL}" ><img border="0" src="{random image.THUMBNAIL}" ></a></td>
 
  
    </tr>
<!-- END random image -->
</table>



And the other one looks like this:

$myffcms_options["RANDOMIMAGE"]->component="RANDOMIMAGE";
$myffcms_options["RANDOMIMAGE"]->name="RANDOMIMAGE";
$myffcms_options["RANDOMIMAGE"]->show_title="1";
$myffcms_options["RANDOMIMAGE"]->title="members Photos";
$myffcms_options["RANDOMIMAGE"]->postable="1";
$myffcms_options["RANDOMIMAGE"]->guest="0";


This is why I have been getting confused. This is what my overall_header looks like:

Code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{S_CONTENT_DIRECTION}">
<head>
<meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}">
<meta http-equiv="Content-Style-Type" content="text/css">
{META}
<title>{SITENAME} :: {PAGE_TITLE}</title>
<link rel="stylesheet" href="templates/myff_bedfordmoms4/{T_HEAD_STYLESHEET}" type="text/css">
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
   if ( {PRIVATE_MESSAGE_NEW_FLAG} )
   {
      window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');;
   }
//-->
</script>
<!-- END switch_enable_pm_popup -->

</head>
<body leftmargin="0" topmargin="0">

<a name="top"></a>

<table width="97%" cellspacing="0" cellpadding="10" border="0" align="center">
   <tr>
      <td><table width="100%" cellspacing="0" cellpadding="0" border="0">
         <tr>
            <td><a href="{U_INDEX}"><img src="templates/myff_bedfordmoms4/images/bedfordmomslogo.gif" alt="{SITENAME}" border="0"></a></td>
            <td align="center" width="100%" valign="middle"><span class="maintitle">{SITENAME}</span><br /><span class="gen">{SITE_DESCRIPTION}<br />&nbsp; </span>
            <table cellspacing="0" cellpadding="2" border="0">
               <tr>
                  <td align="center" valign="top" nowrap="nowrap"><span class="mainmenu"><a href="{U_FAQ}" class="mainmenu">{L_FAQ}</a></span><span class="mainmenu"> :: <a href="{U_SEARCH}" class="mainmenu">{L_SEARCH}</a> :: <a href="{U_MEMBERLIST}" class="mainmenu">{L_MEMBERLIST}</a> :: <a href="{U_GROUP_CP}" class="mainmenu">{L_USERGROUPS}</a>
                  <!-- BEGIN switch_user_logged_out -->
                  :: <a href="{U_REGISTER}" class="mainmenu">{L_REGISTER}</a></span>
                  <!-- END switch_user_logged_out -->
                  </td>
               </tr>
               <tr>
                  <td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu"><a href="{U_PROFILE}" class="mainmenu">{L_PROFILE}</a> :: <a href="{U_PRIVATEMSGS}" class="mainmenu">{PRIVATE_MESSAGE_INFO}</a> :: <a href="{U_LOGIN_LOGOUT}" class="mainmenu">{L_LOGIN_LOGOUT}</a></span></td>
               </tr>
            </table></td>


         </tr>
<table width="10%" cellpadding="4" cellspacing="1" border="0" class="forumline" align="left center">
   <tr>
        <th colspan="1" width="15" height="15" class="thCornerL" nowrap="nowrap">CURRENT TIME</th>
     </tr>
  <tr>
   <td class="row2">


<span class="forumlink">
<script type="text/javascript" src="/portal_clock.js"></script>
<script language="JavaScript" type="text/javascript">show_clock()</script>
</span>


</td>
  </tr>
</table>
{MYFF.RANDOMIMAGE}


I did the {MYFF.RANDOMIMAGE} Just like  you said but on my forum screen you see the first randomimage.tpl that I just posted.
myff admin

the template files must have slightly different names?

$myffcms_options["RANDOMIMAGE"]->component="RANDOMIMAGE";
$myffcms_options["RANDOMIMAGE"]->name="RANDOMIMAGE";
$myffcms_options["RANDOMIMAGE"]->show_title="1";
$myffcms_options["RANDOMIMAGE"]->title="members Photos";
$myffcms_options["RANDOMIMAGE"]->postable="1";
$myffcms_options["RANDOMIMAGE"]->guest="0";

is totally wrong and the file should be deleted.
Christina

Which one do you recommend for me to delete?
Christina

thank you so much!!! i just went to the 2nd randomimage and under the cms thing. i then hit delete. it is still under there but now both codes are the same and it is that 2nd one i showed you. well when i did that my picture box is now there!!

go check it out! www.bedfordmoms.myfreeforum.org


THANK YOU AGAIN FOR BEING PATIENT AND HELPING ME THROUGH THIS. I KNOW YOU HAD TO GET ANNOYED AFTER A WHILE BECAUSE I DID!!! BUT THANK YOU FOR NOT GIVING UP ON ME!

       myfreeforum.org Forum Index -> Portal components
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum