Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Running your community
Daniel(u1bd2005)

Report Post Addition V2.0

OK, with the small update Admin put in this morning I updated the report post button I made a while ago to now work Via PM.


1. Goto Administation Panel.
2. Goto Styles > Portal Settings
3. Create BLANK Portal
4. Fill in details as below.

5. Click "Create New Portal" to save the changes.




6. Goto Styles > Edit Templates/Logos
7. Edit the template you wish to add the report option to.
8. In the "Choose Portal template File to Edit" find "cms_report.tpl"
9. Delete the code and type the following.
Code:
<a href="http://yourforum.myfreeforum.org/privmsg.php?mode=post&u=2&subject=report%20post%20http://yourforum.myfreeforum.org/{U_VIEW_TOPIC}"><img src="http://img174.imageshack.us/img174/324/reportxn6.gif" border="0"></a>

(You only need to change the forum address and if you want to you can change the url of the image.)
10. Click Submit.

The image I have provided is




11. Edit the viewtopic_body.tpl
12. Find
Code:
{postrow.QUOTE_IMG}

13. Before it add
Code:
{MYFF.REPORT}

14. It should look something like
Code:
<td valign="top" nowrap="nowrap">{MYFF.REPORT} {postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td>


15. Click submit and your done.

Heres what it will look like. (remember, you can change the image if you wish its totally upto you.)


Upon clicking the button the PM page will open with the following allready filled out.
myff admin

Congratulations on a nice hack

This is what portals are meant to be about. Allowing people the power to customise.
symon

Sorry but i do not see the difference here between the way this is set up and using a simple pm.

The way you have set this up does not infact report the post at all , all it seems to do is send a pm with a too long topic title which is not a lnik and you can not infact see the end of the title to see which post they are reporting.
Daniel(u1bd2005)

are you sure you've copied the code right? on my forum it automatically fills in the full url as the subject, if its just displaying http://testhtml.myfastforum.org/viewtopic.php?t= for you then I dont know why, it fills it all out for me as you can see in my last print screen.
symon

I can not see your last image as your using image shack and no hotlinking is showing.

Yes it fills out the full url but it is too long to display it as the screen shot shows.
Daniel(u1bd2005)

here, as you can see on mine it has automatically filled in the full url in the subject of the message.


what is the exact code you have in the cms_report.tpl file?

how come its too long on yours and not on mine?
symon

Yes i agree with that, as you are showing what it looks like before you send. but once you send the pm it shows like my screen shot with no visable link to it.
Daniel(u1bd2005)

Symon wrote:
Yes i agree with that, as you are showing what it looks like before you send. but once you send the pm it shows like my screen shot with no visable link to it.


It still shows the full link once I send it, i don't know why yours isn't.

symon

I copied the code right but i have found a few problems


    On some templates the subject line is too long and there for will cut out.

    The report will only go to the Admin`s PM

    There is not clickable link and you have to spend time posting a message


I have come up with i think a better solution.

    This one sends a message to the Forums email account, (as many forums have one email account that all admins have access to .)

    The  admin would get an email (if they have turned off pm alert they would not see your one until they signed in)

    All fields are all ready filled in for you .

    Only one simple code entry is needed no need for portals or cms pages


http://testhtml.myfastforum.org/about32.html  use the report icon.
TFT™

I actually really like the system Daniels put together here. Like Symon said, it only PMs the admin, which I find a slight draw back. But the URL appears in it's entirety in my template too, and the system works real well.


I really don't like the idea of a report system sending reports (even if the reports themselves are more efficient and more relevant) to my email. I hate anything that forces me to open up and use another site. For one it's unreliable and slow for a report system method. I'm always on the forum when I can, but I only check my email once a day or so. For posts that require urgent attention I think it stands a chance of the admin reaction being slow. Unless of course you want to keep a eye on your email 24/7. But that's just me personally, I hardly use my email, I try and keep it all on-site, as I already have enough tabs open.


Also, I think it's better than manually PMing a staff member, as often some members may be unsure as of who to PM. The subject title also informs the staff straight away that it's a report message, and won't be mistaken for a normal PM if the user hasn't put a relevent subject title. And at the end of the day you still have the PM option there anyhow. ^_^ So why not augment a good system and make it better?  Dunno who to see or ask? Dunno who would deal with the issue? Doesn't matter, member just has to hit report and then submit, and it's all taken care off.


As for posting a message itself as the report format, to me that's fine. I always prefer to add a comment/reason when I report something, as it's not always clear to the moderator, and it's not always black & white issues being reported. Plus it may also save you having to PM the user for further info if the reason for the report isn't obvious.

Ideas/Feedback (from a novice):
- Make the system forum-specific. Instead of site-specific. A report in my off-topic forum will be recieved by my OT forum moderator. A report in my War Forum goes to the War Forum mod etc. Coding for this would likely be a nightmare? I don't know, but it's just my idea.  

- Add a default intro line in the message box of the PM itself. eg. [Please type the reason you are reporting this topic/post here]

Anyhow, thanks for the hack!
TFT™

** playing with the feature again on another system and I notice one critical problem though XD

Today I was surfing my forum, testing the report function on the PCs at work. At work we're using Windows 2000, and Internet Explorer. The function worked like a charm, although when I got home and kept testing it on my home system (XP Pro, and using Firefox) I find each time I report a post, the URL it gives me in the report subject is always "report post http://bikinilines.myfastforum.org/viewtopic.php " regardless of what topic/post I report, and now will not seem to link me to the actual threads themselves.

No other changes, simply logged out on one system, logged in on another, no settings or portal/code changes since it was working on IE.

Just for info! I'll try again when I'm on IE tomorrow.
Daniel(u1bd2005)

TwistedFairytale wrote:
** playing with the feature again on another system and I notice one critical problem though XD

Today I was surfing my forum, testing the report function on the PCs at work. At work we're using Windows 2000, and Internet Explorer. The function worked like a charm, although when I got home and kept testing it on my home system (XP Pro, and using Firefox) I find each time I report a post, the URL it gives me in the report subject is always "report post http://bikinilines.myfastforum.org/viewtopic.php " regardless of what topic/post I report, and now will not seem to link me to the actual threads themselves.

No other changes, simply logged out on one system, logged in on another, no settings or portal/code changes since it was working on IE.

Just for info! I'll try again when I'm on IE tomorrow.


It looks like thats a problem in FireFox, I just tried in firefox and im having the same problem, fine in IE though.
Looks like thats why it wasn't working for Symon when he tried it.

Not sure what I can do to fix this  
TFT™

Daniel(u1bd2005) wrote:
It looks like thats a problem in FireFox, I just tried in firefox and im having the same problem, fine in IE though.
Looks like thats why it wasn't working for Symon when he tried it.

Not sure what I can do to fix this  

Hey Daniel ^_^

Yeah, I was about to post again when I saw you'd already tested it. Had a few friends try it also last night using both browsers and they also found the same thing.

Hehe, well, I sure don't know what could be done about it, I am but a peon. But I'll play with my browser options a little and see if it makes a difference at all.

Sad that it's like that with FF, as it's such a good system you've put together for reports I feel. Hopefully there's a way to rectify it, if not though it's still all good!

While your here though, I will ask, as someone who knows almost nothing about coding: How realistic/hard would it be to have the existing system you've made PM those members who are assigned as mod for a forum? e.g. Someone reports a post, the PM is then directed to all users who are listed as moderator for that particular forum/subforum. Possible? Or a huge job?
Daniel(u1bd2005)

TwistedFairytale wrote:
While your here though, I will ask, as someone who knows almost nothing about coding: How realistic/hard would it be to have the existing system you've made PM those members who are assigned as mod for a forum? e.g. Someone reports a post, the PM is then directed to all users who are listed as moderator for that particular forum/subforum. Possible? Or a huge job?


It may be possible, but then again it will also probably be a huge job, I will play about with it later and see if I can get it working like that.
Kai

Is there a way to make a certain member be sent the pm, I didn't originally make my site
Andrew(AP)

yes...

If you're using daniels code then just simply change the user id, (which can be found when viewing there profile)

Code:
<a href="http://yourforum.myfreeforum.org/privmsg.php?mode=post&u=                             Add the id here                &subject=report%20post%20http://yourforum.myfreeforum.org/{U_VIEW_TOPIC}"><img src="http://img174.imageshack.us/img174/324/reportxn6.gif" border="0"></a>

hehe, i dont think i could add bolds in codes so what you need to do is find the id and replace all them spaces and the words with the id

so lets say im sending it to my moderator which has a id of 32442345

the new code would be

Code:
<a href="http://yourforum.myfreeforum.org/privmsg.php?mode=post&u=32442345&subject=report%20post%20http://yourforum.myfreeforum.org/{U_VIEW_TOPIC}"><img src="http://img174.imageshack.us/img174/324/reportxn6.gif" border="0"></a>


get what im saying?
Kai

I cant find the id, the ip ?
Andrew(AP)

hoover your mouse over your username, if you look down in the status bar, it will show the id at the very end of the link.


or

click on your username.

then it will show it at the end of the link in the address bar.
myff admin

Note that an "official" post reporting system is awaiting deployment to the servers.
Kai

Thanks, I'm giving you Karma for that
Andrew(AP)

hehe, It didn't seem to raise my 3 rating. I'm very disliked on this forum  Wink

*crys in corner*
Kai

Don't cry  

       myfreeforum.org Forum Index -> Running your community
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum