Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Web page/template Editing
scotty

Online Offline buttons colour change

This is my forum
http://diecastrescue.myfreeforum.org/index.php

I recently added the online offline buttons to my forum under the users avatar, i would like to change the colour of the buttons to match the rest of my forum, at this part of my forum.

http://diecastrescue.myfreeforum.org/ftopic236-10.php

You will see the online offline button is blue but when you look at the other buttons, Profile, pm and email they are red i would like to match them up so they all look the same.

I have searched for online, offline and even colour but cant find what i am looking for.

Any help would be appreciated

Scotty
GentleD

You may just need new graphics for the online/offline. I am sure Admin will let us know when he comes on. Just in case you do, I did some in red for you.

Kat



scotty

Thank's for doing them Kat

Only thing i would change on the ones you did is the online bulb bit back to green as it looks better.

Think i will need to wait for Admin as i am not sure how to add them as i am new to doing this forum stuff.

Scotty
GentleD

Okay, here is the one with the green light bulb.

Kat


scotty

Thank's they should do the job when i figure out how to get them on to my forum.

Scotty
GentleD

I am thinking you should be able to upload them just like you did the main logo. I kept the file names the same as what they were, so don't change those.

Bravo or Admin can correct me if I am wrong about that.

Kat
Nick(NR)

no, but sort of.......................read on............

http://howtodoit.myfreeforum.org/...component=content&topicid=722

you can add the images more easily with the web page addition and use the direct links from there.
scotty

Just had a quick look and its the same place where i first did the online offline but i have to mess about with code from what i cant make out so will have to read it a couple of times then give it a go, its good there is no rush main thing is i was asked for the online offline by a member and its there and when i figure out how to do the colour change i will do it.

Thank's
Scotty
scotty

I have tried to change them i uploaded the new buttons to the template and nothing happened when i tried to change them in the Portal Settings they ether disappeared or stayed blue so looks like they will just have to stay looking wrong for now as this template editing is not easy
Nick(NR)

could you link us to a guest viewable topic, so we can see the icon or the red box, to help us see where the problem may lie
scotty

Hi all pages on my forum should be guest viewable and here is one of them.

http://diecastrescue.myfreeforum.org/about310.html&highlight=

You can see the online / offline are blue where as under the posts the profile, pm and email are red i am trying to match them up.

The light bulb part i would like to stay green for online as it looks better.

Thank's
Scotty
Bravo

online should go in: images/icon_online.gif
offline: images/icon_offline.gif
scotty

That is what i did but it did not work so i must have did something wrong but cant see what.
Nick(NR)

can I suggest then that you alter the filenames of the red online/offline images and add new_ at the start of the filename and upload those and alter the path name in the portal settings, that link to the images.

As I'm a bit lost on why they haven't changed yet and it can't be a cache issue as I've not looked at your forum prior to a minute ago, so hopefully the altered filenames should do the trick.
scotty

Just to make sure i have it right i should upload them like this.

images/new_icon_online.gif

images/new_icon_offline.gif

Then change them to match in the Portal settings.
Nick(NR)

Yup
scotty

Still no luck i thought i found out what i did wrong as i changed the text for the icons to.

new_icon_online.gif

new_icon_offline.gif


and noticed they where going to upload as

new_icon_online.gif.gif

new_icon_offline.gif.gif


so i though that is where i went wrong so changed to this.

new_icon_online

new_icon_offline


and that added them as they should be i then went to portal settings and changed it there but when i looked at my forum the buttons had vanished so i went back to portal settings and removed the new_ and the buttons where back the way they where before but something i notice was.

icon_online.gif

icon_offline.gif

new_icon_online.gif

new_icon_offline.gif


where not in the drop down list on the edit page and this has confused me as to how the buttons could be working without them so i have added them again as.

icon_online.gif

icon_offline.gif


To make sure all is ok again but this is not making any seance why they are not changing as they should and how they vanished at one point and i had to add them again.

Scotty
scotty

Forgot to say

icon_online.gif

icon_offline.gif


are now on the red buttons and i uploaded them that way.
Bravo

scotty wrote:
That is what i did but it did not work so i must have did something wrong but cant see what.


Did it go to the images folder, or to a template folder?  What was the filename path shown at the top of the page when you uploaded the image?  Nick's solution will also work fine, but I think it may be as simple as checking you have placed the image into the right folder
scotty

Decided to do print screen and save the image so you can see as its easier than trying to explain.

Not sure what file path you are asking for when i uploaded so i will say both i see at the top.

Forum template (agreement.tpl)

Select Image (cellpic.gif)

The red X's are where i uploaded the button images (not exactly in that box) i used the "Chose File" then "Upload"

Also added what they look like on my PC when uploaded.
 


Nick(NR)

see that bit saying "Upload Image Path relative to:" that then has myff_diecastrescue1 you may want to set that up in the portal settings to reflect that Wink

Code:
myff_diecastrescue1/images/new_icon_online.gif

myff_diecastrescue1/images/new_icon_offline.gif
scotty

Did exactly what you said and still not working in Google Chrome it looks like in the photo and FireFox there is nothing there all.


       myfreeforum.org Forum Index -> Web page/template Editing
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum