Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Portal components
DSi

MODACTIONS Help

I'm trying to get the MODACTIONS portal working on my forum ( http://24forum.net or http://24.myfreeforum.org ), and no matter what I do, I always get a blank actions.php screen, like so: http://img299.imageshack.us/img299/8488/actionphpfj4.jpg

Here is what the MODACTIONS settings look like: http://img299.imageshack.us/img299/3070/modactionskl9.jpg
It's not just set active/inactive, there are a bunch of other things too with the same settings.
Yes, I am part of the defined usergroup (Super Moderators).

When I click on "Moderate User" from a post or in a profile, that is the screen I get ( http://img299.imageshack.us/img299/8488/actionphpfj4.jpg ), instead of seeing all of the options I set.

Please help me!  

Thanks in advanced.

-DSi
myff admin

Is it really blank? or are is the style making it look blank?
DSi

It actually is blank, it was working before, when the Trigger Members was set to Admins and Mods, but then I changed it to Super Moderators, and it wasn't working. When I changed it back to see if that was the problem, it still wasn't working.
myff admin

I would play with the template and see if the switches are working. e.g:

<!-- IF MODACTIONS_SETINACTIVE_ALLOWED == 1 -->

is the bit that controls the set inactive checkbox, maybe the switch is not set, or maybe there is a javascript error preventing display, are you seeing javascript errors?
DSi

admin (no pm's please) wrote:
I would play with the template and see if the switches are working. e.g:

<!-- IF MODACTIONS_SETINACTIVE_ALLOWED == 1 -->

is the bit that controls the set inactive checkbox, maybe the switch is not set, or maybe there is a javascript error preventing display, are you seeing javascript errors?

No, I'm seeing no errors, just a blank MODACTIONS screen, as I showed in the picture I linked in my first post.

I'm pretty sure it's not the template, because it was working originally, but now it's not.
myff admin

You need to check and recheck the modactions, it was working and now its not, so what changed?
DSi

I've checked and rechecked the MODACTIONS countless times, and the only thing that was changed was the Trigger Member. I'll check again tomorrow, but I'm almost positive that was the only thing that was changed.
myff admin

http://24forum.net/action.php?action=MODACTIONS&popup=2&u=164

works for me, I changed the "who can trigger" bit to "mods and admins". You did say:

"When I changed it back to see if that was the problem, it still wasn't working."
myff admin

and as suggested ealier looking as you I see:

Error: unterminated string literal
Source File: http://24forum.net/action.php?action=MODACTIONS&popup=2&u=164
Line: 577, Column: 29
Source Code:
adminmod_messageObj.value = "The following message has been sent to \"whycantkimdie?\"



e.g. bust javascript.
myff admin

it is where you have edited the template. The default template has:

adminmod_messageObj.value = "The following message has been sent to \"{MODACTIONS_TARGET_USERNAME}\"

Quote:
"+messageObj.value+"
";

you have appended that and added a hardline break which is a javascript syntax error.
myff admin

I might point out my first two posts said look at the style and javascript, and you carried on saying that was not wrong, without ever using the editor to check a default version of the template, or looking for javascript errors which firefox clearly reported and so does ie7.
DSi

Wow, thanks admin, I never would've caught that... I guess my OCD just got to me and I had to put that hard linebreak in there

Also, how do I change the subject (or message) of the PM in the MODPMESSAGE in order to show the username of the admin/mod that changed the user's settings? I tried putting {MODACTIONS_TRIGGER_USERNAME} in the subject line via cms_modactions.tpl, but it didn't work. Any ideas?
myff admin

Can you expand on how you did {MODACTIONS_TRIGGER_USERNAME}? and what the result was?

It should work, but it is complex stuff and there are probably still bugs.
DSi

admin (no pm's please) wrote:
Can you expand on how you did {MODACTIONS_TRIGGER_USERNAME}? and what the result was?

It should work, but it is complex stuff and there are probably still bugs.

I tried putting it in the PM subject line, and in the PM message (first without the \", then with the \"), and neither of them worked, it acted as if it just weren't there, so it just showed something like "" instead of the trigger username.
myff admin

if just added "by {MODACTIONS_TRIGGER_USERNAME}" in the subject line here and modded you.

my pm got the by bit right. Did you get it?
DSi

admin (no pm's please) wrote:
if just added "by {MODACTIONS_TRIGGER_USERNAME}" in the subject line here and modded you.

my pm got the by bit right. Did you get it?

Yeah, I got this as the subjcect line: Your account has been edited by an admin/mod by {admin (no pm's please)

I'll try it again on my forum...

Nope, still not working, all I get for the subject line is this: The account "editor" has been edited by

Here's my code:
Code:
adminmod_subjectObj.value ="The account \"{MODACTIONS_TARGET_USERNAME}\" has been edited by {MODACTIONS_TRIGGER_USERNAME} ";
myff admin

Oh I see, you are doing the substitution in the Javascript itself.

I don't think the trigger macros are defined at that point. I am using the macros in the portal definition.
DSi

admin (no pm's please) wrote:
Oh I see, you are doing the substitution in the Javascript itself.

I don't think the trigger macros are defined at that point. I am using the macros in the portal definition.

Where is the portal definition then? Besides, the TARGET macro is defined there, wouldn't the TRIGGER macro be defined as well? Or maybe the TRIGGER macro isn't defined at all in my template? Could that be possible?
myff admin

The PM definition is in the MODACTIONS portal just look for it.

trigger macros should probably be defined in the javascript and I will try and add that soon.
DSi

admin (no pm's please) wrote:
The PM definition is in the MODACTIONS portal just look for it.

trigger macros should probably be defined in the javascript and I will try and add that soon.


Oh, I see what you're saying now! I thought you meant in the cms_modactions.tpl template file

It's working flawlessly, thank you so much admin! I'm sorry for the trouble
james73

modactions problem

http://urbanglasgow.myfastforum.org/

I've turned on the modactions, added my own image for the link and it seems to be working.

http://i48.tinypic.com/300cy2e.jpg


However, when you click on it all the info that is usually at the bottom of the screen is shown
on the extreme right hand side, as shown. Can anyone help with this? Also, is there a way to
remove or edit the 'Walk on the Wild Side' text at the bottom of the page? I think it was added
when the forum was created.

http://i49.tinypic.com/2d9hqh.jpg


Cheers

James H
myff admin

MY guess if the text is footer text that you may find in the control panel:

http://myfastforum.org/index.php?...amp;task=loginforum&Itemid=27
james73

Looks like someone fixed it. Many thanks.

http://i49.tinypic.com/adizdj.jpg


James H

       myfreeforum.org Forum Index -> Portal components
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum