Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Off Topic
Zudane

Automod

Well.. tried setting up a new site.  Done this a few times, and I've enjoyed using automod each time... but this time, I got the site running, install automod.. and.... it doesn't work.

Why not?  It's saying that files are unwritable (which files vary each time I try to run it).  I try ftp, it gives an error that the password or username is wrong - immediately after the test connection works.

Looking up the problem... people are told to make sure that files are writable.  Since php is running it through the server then the owner needs to be able to write - which all files are currently.  I've checked two other sites to be sure that permissions are identical and that configuration is identical.... and they are.  Yet this one doesn't want to work.

I've cleared and restarted the domain and tried again.. with the same results.  I'm plum ready to give up on it.
editor

Well generally files see not owned by the http process, so files need to be writable by that process.
Zudane

The files were even world writable at one point.  But I've never had a problem up until this instance.  I just can't understand why this didn't work.  I used the same files all off of my computer that I used last time.
myff admin

What is the hosting, what are the  exact ownership and permissions of problem files?
Nick(NR)

So wait, let me get this right, you uploaded all the files for this particular mod, then went to install it, using automod.

did you not change the file permissions as per the install readme via the ftp before running the automod installer?
Zudane

The problem is that even automod isn't installing correctly.  The file permissions are what they should be - they are properly editable via the php.  But no file changes are being made.  Automod has been giving errors that things are not writable, or is giving a 'success' result - even though nothing is being changed.


What is bothering me, is that I am using the same files for phpbb3, automod, and the same mods that I have used before, and doing them via the same methods, and I am coming up with errors that I cannot explain.

I've tried updating the few errors myself and forced install - and nothing happens, I've even tried FTP and downloading the changed files.  I've also tried setting permissions for the files to be edited to 777.  The FTP is giving random errors and is still not changing files, and downloading the changed files is giving errors.  For example I get a file called "l" and another file called "anguage".  Same is done with the styles (s + tyles) and a few other folders.
Nick(NR)

If the ftp method of setting file permissions isn't allowing you to do so, give your webhost a shout they may have an issue they don't know about as it's not been reported, I can't think of any reason for the ftp permissions to not be allowed, unless there is an issue or your hosts server has been compromised which I've seen happen and would allow permissions changes to files with ftp

So see what your hosts say mate
Zudane

I can go via FTP using the same phpbb settings, I am accessing it that way currently.  I have a vps that I run multiple forums on.  This just has me bugged to no end, because I have a feeling that something somewhere got corrupted.

I guess I'll try a restart of the server to see if anything changes.
myff admin

Doesn't sound like corruption to me. Sorry but it sounds like you not understanding the permissions, perhaps a php safe mode issue as well.

       myfreeforum.org Forum Index -> Off Topic
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum