Archive for myfreeforum.org Before posting please check the "stickies" in the support forums.
Please ask questions in real English and not "txt". You will get a better response.
Please do not ask support questions via PMs.
 


       myfreeforum.org Forum Index -> Portal components
Dean

Actions portal not working

PLEASE ENTER THE FOLLOWING>>>>


Enter your myff forum url here, if the issue is on a particular part of the forum, then give a link to where the problem actually is. Do not enter your own domain name it must be the actual myff link :

http://magicbus.myfreeforum.org/


If you are asking a template related question, what is the name of the template:


Please indicate keywords you have searched on:

Action portal

Now ask your question in clear English without "txt" speak>>>>

Am trying to use a "Command" that will set new members to "disallow replies", as well as "disallow new topics" and "disallow PMs". I am just trying to get the "disallow replies" to work at this time, but, I'm getting this error when testing it. This is what a new member would see after clicking submit when signing up for the Forum.

Code:
Could not select session_ip

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

SELECT session_ip FROM phpbb27225_sessions WHERE session_user_id =

Line : 47
File : functions_log.php


This is a screenshot of how I have the Actions portal setup.



What am I doing wrong?

Thanks.

Dean
myff admin

I don't know, but it does seem to be that that error should not be fatal, so I have tweaked the code.

Can you try again.
Dean

Yes. I will try again.

BTW... I checked and the test account DID have the "Can post replies" set to NO... so, it DID work. However, the test account did NOT receive the PM.

I'll post what happens when I try it again.

Dean
Dean

Code:
Could not select session_ip

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

SELECT session_ip FROM phpbb27225_sessions WHERE session_user_id =

Line : 46
File : functions_log.php


I'm not sure if this is the same error, but, this is what it showed after clicking submit when joining.

Same thing happened. The test account has the "Can post replies" set to NO, so that is working... and the test account did NOT get the PM.

Should I do these two things in two separate Actions and see what happens?
myff admin

My bad

The code was not changed, a save failed silently on me

Try now.
Dean

OK.

All is working perfectly!

Now, when new members register, they automatically get a personalized PM from the admin account, and they are not able to post or PM. Perfect.

Thanks for your help!

BTW... any way this PM can come from another admin (in other words, my account, instead of the main admin account)?

This is what the configuration looks like:

myff admin

Keep it to one support question per thread, if you have another question start a new topic. This will help others using "search" to find answers.

       myfreeforum.org Forum Index -> Portal components
Page 1 of 1
Create your own free forum | Buy a domain to use with your forum